CROZIER Joris
Tutoriel sur l'utilisation de Thunderbird le client mail pour Windows. ♪
Cet article a pour but de présenter l'utilisation de Thunderbird dans un premier temps pour ceux qui en feront un usage basique et ensuite pour ceux qui veulent aller un peu plus loin.
Cet article se base sur la version 1.5.0.9 pour Windows, bien que le client mail soit aussi disponible pour les plateformes Mac et Linux, tout ce qui est décrit dans cet article ne devrait différer que très peu d'une plateforme à l'autre.
Thunderbird est le client mail de la fondation Mozilla, ses principaux atouts résident dans le fait que son développement est constant et donc ses mises à jour sont plus fréquentes que son concurrent direct de chez Microsoft (Outlook pour ne pas le citer ^^ ).
Mais aussi que son moteur de rendu html se base sur celui du navigateur Firefox de la même fondation (et toujours en concurrence directe avec son rival de chez Microsoft : Internet Explorer).
Et encore atout majeur : Thunderbird est entouré de nombreux modules développés par sa communauté tels des plug-ins, thèmes et autres réjouissances !
II-A - Installation
Tout d'abord il faut télécharger le fichier d'installation, si ce n'est pas déjà fait, on peut le trouver ici :
Thunderbird sur Mozilla Europe
Dans le cadre de gauche « Téléchargement », cliquez sur « Windows » (si vous utilisez Windows évidemment ^^) et téléchargez le fichier d'installation sur votre bureau par exemple.
Ensuite un double-clic sur le fichier d'installation et on suit les étapes :
On suit les étapes -> Suivant
On va se faire une installation standard, on se contentera de cliquer sur Suivant jusque la fin.
II-B - Configurer un compte de courrier
À cet instant Thunderbird se lance, une petite fenêtre s'ouvre pour configurer le compte principal, ici nous allons choisir « Compte courrier électronique »
Cochez Compte Courrier électronique
Dans le champ :
- Votre nom, on entre le nom qui s'affichera dans la colonne « De » chez le destinataire, soit votre nom. Exemple « Joris CROZIER ».
- Adresse de Courrier, on entre l'adresse électronique associée au compte. Exemple : « jcrozier@dvp.com ».
Puis on clique sur Suivant
Ici nous allons configurer la manière dont Thunderbird va aller « chercher et envoyer le courrier » :
On a le choix entre Pop/Imap :
POP3/Imap sont des protocoles qui permettent de récupérer les courriers électroniques situés sur un serveur de messagerie électronique.La principale différence entre les deux :- Pop3 télécharge l'intégralité du message depuis le serveur jusque votre client mail (le logiciel Thunderbird) :- IMAP lui se contente de télécharger les entêtes (le nom de l'expéditeur, l'objet et diverses informations concernant l'email), de plus la commande « Suppression » n'est pas prise en compte par ce protocole, les messages sont donc conservés sur le serveur.De ce fait IMAP protège votre pc des virus plus efficacement, car les messages n'étant pas téléchargés sur le client mail, vous ne risquez pas d'ouvrir des pièces jointes compromettantes.Ceci étant dit à l'heure actuelle, la majorité des utilisateurs ont un antivirus qui vérifie le contenu des emails lorsque ceux-ci sont téléchargés sur le client, ainsi la plupart des virus sont détruits avant leur ouverture…
Nous utilisons donc dans la plupart des cas (et dans notre exemple), le protocole Pop3
Dans le champ :
- Nom du serveur, on va donc associer le protocole POP au domaine de l'adresse email du compte.
Dans mon exemple le domaine est dvp.com, ce qui nous donne pour mon exemple pop.dvp.com (usuellement on n'utilise plus le 3 de pop3).
Nous laisserons la case « Utiliser la boite global ».
Puis vient la configuration de l'envoi des mails via le protocole smtp :
SMTP signifie Simple Mail Transfert Protocole (littéralement « Protocole simple de transfert de courrier », il sert à envoyer ses messages à destination des serveurs mails de nos destinataires
Dans le champ :
- Nom du serveur : nous allons entrer le protocole smtp associé au nom de domaine de l'adresse dans mon exemple cela donne : smtp.dvp.com.
Attention : renseignez-vous auprès du service qui « héberge » votre espace mail, car certains prestataires n'utilisent pas ces standards, de ce fait les adresses pop et smtp peuvent différer légèrement !
On clique sur suivant !
On vous demande maintenant les noms entrant et sortant, ceci correspond à votre login sur l'adresse mail :
selon votre « hébergeur » cela peut être le nom avant le @, voire l'adresse complète !
Dans mon exemple ce pourrait être : jcrozier ou jcrozier@dvp.com (remplissez les deux champs par la même valeur).
On clique sur Suivant
Insérez ici le nom du compte, c'est ce nom qui s'affichera dans la liste de vos comptes !
On clique sur Suivant !
Le récapitulatif de notre compte !
Voilà c'était pas si compliqué finalement, non ?
On va cocher la case « Télécharger les messages maintenant » et cliquer sur Terminé.
II-C - Recevoir son courrier
Une petite fenêtre s'affiche
Une petite fenêtre s'ouvre et vous demande le mot de passe du compte pour aller cherche votre courrier.
Vous pouvez cocher la case « Utiliser le gestionnaire de mots de passe pour retenir ce mot de passe ».
Vous verrez c'est aussi très pratique on évite de retaper le mot de passe à chaque relève du courrier.
Évidemment on va taper le mot de passe de l'adresse mail dans le champ prévu à cet effet !
L'écran principal
Voilà notre écran principal, il se compose de trois parties.
1 - L'arborescence des dossiers :
Courrier entrant : le dossier où vos mails arrivent par défaut ;
Messages en attente : les mails en attente d'envoi sont placés ici ;
Brouillons : les messages enregistrés comme brouillons ;
Envoyés : les messages envoyés ;
Corbeille : les messages supprimés.
2 - La fenêtre des entêtes des messages du dossier choisis dans la fenêtre 1.
3 - La fenêtre d'affichage du corps du message choisi dans la fenêtre 2 :
La barre d'outils Thunderbird
Pour relever le courrier de ses comptes mail, un petit clic sur Relever et les messages sont téléchargés dans Thunderbird.
II-D - Écrire un mail
Sur notre barre d'outils, on va cliquer sur Ecrire, une fenêtre s'ouvre
La fenêtre création d'emails
Nous voici face à notre fenêtre ! La barre d'outils comprend plusieurs boutons :
Envoyer : envoie notre mail :
Contacts : ouvre le carnet d'adresses (nous en reparlerons plus tard) ;
Orthographe : permet de choisir la langue du dictionnaire utilisée pour corriger les fautes dans le message (nous reparlerons de l'ajout de dictionnaire plus tard) ;
Joindre : permet de joindre un fichier à notre email. N.B. Attention vous ne pouvez pas joindre des fichiers trop volumineux à vos emails, la plupart des hébergeurs préconisent de ne pas dépasser les 2 Mo, mais ceci peut varier selon les prestataires !
Sécurité : pour chiffrer ses emails (nous en reparlerons plus tard) ;
Enregistrer : permet d'enregistrer son mail, soit comme Fichier au format texte, soit comme Brouillon, soit comme Modèle, permettant dans le troisième cas de se servir de l'email sans le retaper à chaque fois !
Le champ Expéditeur : l'expéditeur du mail (à savoir : vous-même lol), ce champ représente une liste déroulante, car, il y a autant d'expéditeurs que vous avez de comptes configurés dans Thunderbird. Vient ensuite un cadre réservé au destinataire, on peut y voir un tableau colonne, la première représentant le mode d'envoi au destinataire, la seconde est réservée à l'adresse de celui-ci !
Le mode d'envoi :
Pour : le mail est transmis à cette adresse simplement, c'est le destinataire principal ;
Copie à : le mail est envoyé au destinataire principal, et une copie est adressée au(x) destinataire(s) de cette ligne N.B. Le destinataire en copie peut voir l'adresse du destinataire principal dans les entêtes du mail ;
Copie cachée : le mail est envoyé au destinataire principal, et une copie est adressée au(x) destinataire(s) de cette ligne N.B. Le destinataire en copie ne peut pas voir l'adresse du destinataire principal dans les entêtes du mail ;
Répondre à : cette option permet de spécifier une adresse mail de réponse différente de celle utilisée pour l'envoi du mail, ainsi le destinataire en cliquant sur Répondre enverra la réponse à l'adresse spécifiée ;
Faire suivre à : une copie du mail est transférée à l'adresse spécifiée.
Le champ Sujet, désigne donc l'objet principal, ce sujet s'affichera chez l'expéditeur dans l'entête du message (dans nos emails reçus, dans la fenêtre 2 de notre page principale).
Le cadre d'édition du message : ici, on tape le corps du message, par défaut les dictionnaires sont activés, les mots jugés mal orthographiés seront soulignés en rouge ! Un clic droit dévoilera une proposition d'orthographe du dictionnaire !
Par défaut les messages sont envoyés au format texte, la barre d'outils entre le champ sujet et le cadre d'édition du message, permet tout comme dans un logiciel de traitement de texte, de mettre en forme son message, et d'y insérer des images.
Dans ce cas le mail sera envoyé en html.
Une fois le mail terminé, les destinataires choisis et le sujet défini (vous pouvez laisser le sujet vide, mais Thunderbird vous demandera de confirmer ce choix avant l'envoi du mail), vous pouvez envoyer votre message en cliquant sur Envoyer.
II-E - Supprimer ses mails
Lorsque vous supprimez un mail, il va directement dans le dossier Corbeille, mais il n'est pas pour autant supprimé, il est encore sur votre disque dur et prend de la place !
Plusieurs solutions pour vider définitivement le dossier Corbeille :
- un clic droit sur le dossier Corbeille, puis Vider la Corbeille ;
- une méthode automatique plus pratique : dans le menu Outils -> Paramètres des comptes - > puis dans le menu Dossier locaux cf.. Image :
On coche la case Vider la corbeille en quittant, les messages seront supprimés chaque fois que Thunderbird sera fermé.
II-F - Quelques Options dites 'Avancées'
Dans le menu Paramètres des comptes, sur la ligne Paramètres Serveurs de vos comptes email, vous pouvez modifier plusieurs options :
Vérifier le courrier au lancement : le courrier est relevé à chaque lancement de Thunderbird.
Vérifier les nouveaux messages toutes les : spécifier un délai en minutes et Thunderbird vérifiera les boites mails à intervalles réguliers (nécessite que Thunderbird soit allumé).
Télécharger automatiquement les nouveaux messages : les messages sont téléchargés en complet depuis le serveur.
Récupérez les entêtes uniquement : seuls les entêtes sont téléchargés augmentant la vitesse de récupération des mails et diminuant le risque de télécharger un virus, en cliquant sur l'entête du mail lors de la lecture, Thunderbird vous demande si vous voulez télécharger le reste du message (donc le corps).
Laisser les messages sur le serveur : permet de laisser une copie du message sur le serveur, idéal lorsque vous récupérez vos mails sur le Thunderbird d'un autre poste, vous pouvez à nouveau les récupérer chez vous par la suite !
II-G - Filtre AntiSpam
Avec Thunderbird, on peut efficacement trier ces mails lors du téléchargement de ceux-ci et sans aucune action de notre part !
Il est capable de reconnaître le spam (et en cas d'échec apprendre et se perfectionner), rendant ainsi plus agréable la relève du courrier !
On va donc l'activer : cliquez sur Outils -> Gestionnaire des indésirables
Une fenêtre vous expliquant le gestionnaire s'affiche (cf. ci-dessous ) : un clic sur OK !
Puis la fenêtre principale s'affiche :
La fenêtre principale du gestionnaire des Indésirables
Nous allons donc faire quelques petits réglages rapides :
Configurer les paramètres du Courrier Indésirable pour : on laisse Dossier locaux.
Onglet Pamamètres : on coche la case Ne pas marquer les messages indésirables si l'expéditeur est dans : Adresses Personnelles, ce qui aura pour effet de faire confiance à vos adresses contenues dans le carnet d'adresses.
On laisse la case décochée.
Se fier aux entêtes de courrier indésirables placées par : utilisée en parallèle de SpamAssassin ou SpamPal, mais vous verrez Thundebird se débrouille très bien tout seul à la longue !
On coche Déplacer les messages entrants identifiés comme Indésirables vers puis on coche Dossier Indésirable sur et on laisse Dossier Locaux, les messages seront donc redirigés dans ce dossier s’ils sont reconnus comme Indésirables !
Prenez l'habitude surtout au début de vérifier le contenu du dossier Indésirables, car dans un premier temps certains mails voulus risquent de finir ici !
Cocher la case Supprimer […] au bout de 14 jours (ou moins) en prenant garde à ma remarque juste au-dessus, sinon ne cochez pas cette case, mais videz votre dossier Indésirables régulièrement !
Enfin cochez la case Assainir l'Affichage des […], qui aura pour effet de n'afficher qu'en partie les messages indésirables et vous protéger d'éventuels scripts inclus dans les mails
Onglet Filtre Adaptatif : cochez la case Activer la détection adaptative […], ceci pour que Thunderbird apprenne à reconnaître le Spam et en laisse passer de moins en moins.
Justement comment différencier les mails manuellement ?
Tout simplement en cliquant sur votre mail : dans la barre d'outils de la fenêtre principale Thunderbird se trouve un bouton Indésirables, un clic sur ce bouton et le mail sélectionné est automatiquement géré comme Spam (et nourrit la base informative de Thunderbird).
À l'inverse si un message est considéré comme Spam à tort, on procède de la même manière sauf que cette fois-ci le bouton Indésirables a pris le nom d'Acceptable !
III-A - Utilisation du carnet d'adresses
Nous allons jeter un petit coup d'œil au carnet d'adresses : Outils -> Carnet d'adresses
La fenêtre du carnet d'adresses
Avec la possibilité d'ajouter des fiches : une fiche correspond à une personne, et des listes.
Les listes sont un moyen très pratique d'envoyer un mail à un groupe de personnes sans avoir à entrer toutes leurs adresses une par une
La fenêtre ajout de liste
On choisit : un nom pour notre liste un pseudo. Éventuellement une description.
Et enfin, on entre les adresses des destinataires inclus dans notre liste.
Ensuite lors de la création d'un mail, dans le champ destinataire : il suffira d'entrer le nom ou le pseudo de la liste, Thunderbird se charge de faire le lien !
III-B - Classer vos mails
Il est possible de classer ces emails automatiquement lors de la relève du courrier, nous allons voir comment.
Dans un premier temps nous allons créer un dossier Documents dans les Dossiers locaux (clic droit sur dossiers locaux puis Nouveau Dossier)
Notre dossier Documents
Maintenant on va créer des règles pour filtrer nos mails : cliquez sur Outils -> Filtre des messages.
Notre fenêtre s'affiche :
Dans la boite de dialogue nous avons le choix entre chacun des comptes configurés et Dossiers Locaux (donc tous les comptes confondus).
Et nous allons cliquer sur Nouveau
La fenêtre d'ajout des règles
On entre tout abord un nom à notre règle.
Il faut choisir si notre mail doit remplir TOUTES les conditions que l'on va énumérer ou AU MOINS UNE.
Le premier cadre est utilisé pour les « Conditions » que le mail doit remplir.
Le second cadre est utilisé pour les « Actions » à effectuer sur ledit mail s’il remplit les conditions précédentes.
Exemple
Dans le cadre des Conditions :
première liste déroulante : nous laisserons Sujet ;
seconde liste déroulante : nous laisserons Contient ;
puis dans le champ nous allons mettre : Documents.
Dans le cadre des Actions :
première liste déroulante : nous laisserons Déplacer le message vers : ;
seconde liste déroulante : nous allons aller chercher notre dossier Documents.
On valide ! À chaque fois que le mot Documents sera dans le sujet le mail sera redirigé dans le dossier Documents (simple comme bonjour non ? Lol).
Le + et le - à côté de chaque ligne sert à ajouter une Condition/Action.
III-C - Utilisation du dictionnaire orthographique
Chaque mail que l'on crée peut être vérifié au niveau de l'orthographe, pour ce faire il faut aller chercher le dictionnaire français et l'activer.
Nous allons aller dans Outils -> Options -> Rédaction -> Onglet Orthographe.
On va cocher la case : Activer la vérification pendant la saisie, et chaque mot mal orthographié sera souligné en rouge dans notre mail.
Puis on va cliquer sur Télécharger d'autres dictionnaires (si le français n'est pas présent dans la liste déroulante ce qui est mon cas).
Vous allez être redirigé sur :
http://www.mozilla.org/products/thunderbird/dictionaries.html
Puis on va aller chercher le français (et tous ceux qui vous intéressent si vous écrivez en polonais rien ne vous empêche de télécharger le dictionnaire de cette langue).
On l'enregistre sur le bureau par exemple.
Pour installer le dictionnaire, nous allons ouvrir le gestionnaire d'extension : Outils -> Extensions -> Installer et on va aller chercher le ou les dictionnaires sur le bureau.
On valide et le tour est joué, vous pouvez retourner dans les options et sélectionner votre dictionnaire dans la liste déroulante !
III-D - Déporter le répertoire de fichiers de vos profils
Alors quels avantages de déplacer le dossier où sont stockés nos mails et nos infos sur nos profils ?
Et bien en plaçant le répertoire sur une partition autre que celle du Système d'Exploitation, nous pourrons formater / ou changer de système d'exploitation (voire faire planter le pc quelquefois) sans perdre tous vos mails et vos configurations !
Et en cas d’installation de Thunerbird : plus besoin de tout reconfigurer ! (Toutes ces heures passées à se faire le Thunerbird Ultime savoir qu'il est en sécurité !! ^^).
Dans Outils -> Paramètres des comptes -> Dossier Locaux, nous allons changer le répertoire Répertoire Local, on valide et le tour est joué !
Changement du répertoire local
III-E - Créer des Signatures
À chaque mail envoyé, il est possible de joindre une signature automatiquement, celle-ci peut être de deux formats : Texte ou HTML (permettant l'envoi de texte mis en forme et/ou d'images).
Comment créer une signature ? C'est simple nous allons ouvrir notre éditeur de texte (Notepad sous Windows) et y taper ce que l'on veut !
Une fois votre signature créée, dans Thunderbird, allez dans le menu Outils -> Paramètres des comptes, sélectionnez un compte.
Ensuite cochez : Apposer cette signature et choisissez l'emplacement de votre fichier signature.txt.
Pour une signature Mise en forme, il suffit de rouvrir son NotePad et d'y taper une signature au format html exemple :
Cette fois le fichier sera enregistré avec l'extension .html
Et vous pouvez recommencer l'opération précédente pour attacher la signature à un compte.
Si votre signature html venait à ne pas marcher, vérifiez bien que votre mail est redigé au format html !
III-F - Intégrer un calendrier à Thunderbird
Il est possible comme le fait Outlook, d'intégrer un calendrier à Thunderbird !
Vous pouvez le trouver à cette adresse :
http://www.mozilla.org/projects/calendar/lightning/
Pour les utilisateurs de Windows et de Thunderbird 1.5 minimum le lien direct pour le téléchargement :
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-mozilla1.8/windows-xpi/
Vous enregistrerez le fichier xpi sur le bureau par exemple !
Ensuite dans Thunderbird, ouvrez le menu Outils -> Extensions -> Installer et allez chercher lightening.xpi sur le bureau (ou à l'emplacement de votre choix lors du téléchargement ^^).
Puis Installer maintenant, vous devrez redémarrer Thunderbird !
Ceci fait, vous voici avec un calendrier en bas à gauche ! Celui-ci affiche ses rubriques dans la fenêtre principale de droite à la place des mails !
Votre Thunderbird avec Calendrier
Je vous laisse le soin de découvrir le calendrier qui n'est pas très compliqué en soi !
III-G - Chrome
Qu'est-ce que Chrome ?
Chrome est une interface utilisateur implantée dans vos fenêtres et hors de l'espace de travail en gros ce qui se rapporte aux barres d'outils, barres d'états, barres de progressions, barres de titres et bien d'autres.
Les Fournisseurs de Chrome :
- Contenu : ce sont des fichiers expliquant le contenu des interfaces chrome, généralement des fichiers .xul.
On peut aussi y trouver des fichiers contenant du JavaScript généralement .xbl.
- Local : un répertoire local contient toutes les informations d'une interface chrome indépendante des sources de l'application elle-même par exemple les extensions, les traductions du soft, etc.
Ces fichiers portent souvent l'extension DTD.
- Skin : comme son nom l'indique, ce fournisseur est responsable de l'apparence graphique des interfaces chrome, généralement des fichiers .css et des images.
Le registre de Chrome
Le moteur de Gecko maintient un service appelé « Le registre de chrome » qui fournit les liaisons entre les éléments chrome de l'application et leur localisation physique sur le disque dur.
Concrètement Chrome est donc un ensemble d'éléments fournis par Mozilla pour normaliser la personnalisation de ses suites logicielles comme ThunerBird, FireFox, SeaMonKey et autres…
Nous en resterons volontairement à ce stade sur Chrome pour notre Guide, il fera peut-être l'objet d'un tutoriel complet dans le futur…
III-H - Thèmes et extensions
Vous pouvez changer l'apparence de votre Thunderbird très simplement en allant chercher des thèmes.
Thèmes pour Thunderbird Pour les installer : menu Outils -> Thèmes -> Installer, et il ne vous reste plus qu'à aller chercher le fichier de votre thème téléchargé auparavant !
Vous pouvez aussi ajouter des fonctions (utiles ou non lol) à votre Thunderbird via les extensions :
https://addons.mozilla.org/thunderbird/extensions/
Pour les installer : menu Outils -> Extensions, et il ne vous reste plus qu'à aller chercher le fichier de votre extension téléchargé auparavant !
Je vous laisse le soin de découvrir et choisir Vos Thèmes / Extensions à votre guise !
Je remercie l'Équipe de Developpez.com, les gens qui ont contribué à la mise en place de cet article LG MORAND, et tout ceux qui apportent et apporteront des points de détail susceptibles de corriger cet article !
Avec un développement sans cesse en mouvement, une communauté gigantesque, des thèmes par milliers, des extensions pour toutes les utilisations possibles Thunderbird est un des Tenors des clients mail !
Son utilisation très proche de l'utilisateur lambda, séduit, son évolution permanente ne laisse pas de marbre et sa personnalisation en fait un argument de choix !
En espérant avoir pu vous séduire, et vous apprendre davantage de choses sur ce client mail !
Je vous tire ma révérence !